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Overview

GenAlEx: Genetic Analysis in Excel is a popular cross platform package for population genetic
analysis that runs within Microsoft Excel. GenAlEx offers analysis of codominant, haploid and
binary genetic loci and DNA sequences. Both frequency-based (F-statistics, heterozygosity, HWE,
population assignment, relatedness) and distance-based (AMOVA, PCoA, Mantel tests, multivariate
spatial autocorrelation) analyses are provided. In GenAlEx 6.5 we introduce exciting new features
including calculation of new estimators of population structure: G’g;, G’ g, Jost’s D,,, and F’; via
AMOVA, Shannon Information analysis, linkage disequilibrium analysis for biallelic data, and
heterogeneity tests for spatial autocorrelation analysis. Data export is provided to more than 30
other software packages. New teaching tutorials and extra step-by-step options are included. The
comprehensive independently written guide has been fully revised.

Peakall, R. and Smouse P.E. (2012) GenAlEx 6.5: genetic analysis in Excel. Population genetic
software for teaching and research — an update. Bioinformatics 28,2537-2539.

Freely available as an open access article from:
http://bioinformatics.oxfordjournals.org/content/28/19/2537

Peakall, R. and Smouse P.E. (2006) GENALEX 6: genetic analysis in Excel. Population genetic
software for teaching and research. Molecular Ecology Notes. 6, 288-295.

The software and supporting documentation is freely available from The Australian National
University, Canberra, Australia at the new URL: http://biology.anu.edu.au/GenAlEx




Installation of GenAIEXx 6.5

The procedure for installing GenAlEx 6.5 is the same as for previous versions of GenAlEx.

GenAlEx is provided as an Excel Add-in, a compiled module and its associated GenAlEx menu.
Your downloaded file may initially be in the zipped format. Use the extract option to unzip the
download and save the files to a dedicated folder of your choice. You can work with GenAlEx
directly from this folder. Separate instructions for Excel 2003, 2010 on PC and Excel 2011 for Intel
Mac are provided below.

Notes for PC users: We strongly recommend that you use either Excel 2003, or Excel 2010. Excel
2010 fixed a series of major issues in Excel 2007 including issues that affect the operation of
GenAIEx. Importantly, calculations can be extremely slow in Excel 2007 other versions. It is also
important to ensure that you have the most recent updates for your version of Excel.

Notes for Macintosh Users On Macintosh computers, GenAlEx can be run in Excel 2004 and
Excel 2011 (released in 2010, but badged as 2011), but not Excel 2008. This is because Microsoft
removed the ability of Excel 2008 to run Visual Basic for Applications (VBA), the macro language
of Microsoft Office. Note that Excel 2011 can only be run on Intel-based Macs. Be sure to read the
readme file for Mac users, as there are some minor issues you need to know about. It is also critical
to ensure you have the very latest update (at least 14.2.1 for Excel 2011). Several GenAIEx issues
are due to bugs in early releases of Excel 2011.

Loading GenAIEx in Excel 2003 on PC

Step 1. Copy the GenAlEx Add-in to your choice of location on your computer. This should
preferably be in a dedicated folder.

Step 2. Launch MS Excel. Choose Open from the File menu, locate the GenAlEx Add-in, then
click the OK button.

Tip: Alternatively, you can launch GenAlEx and Excel simultaneously by clicking directly on the
GenAlEx Add-in file.

Step 3. Depending on the settings of your Excel program, Excel may warn you that
GenAlEx contains macros. Click the Enable button to proceed.

SecuriyWarning X

"C:\Documents and Settings\Rod Peakall\My Documentsiwork 2009 PCY\GenAlEx 09
PC\GenalEx 6.3b2T\GenalEx 6.3b2T.xla" contains macros.

Macros may contain viruses. It is usually safe to disable macros, but if the macros are
legitimate, you might lose some functionality.

| Disable Macros | [ Enable Macros l [ More Info l

Step 4. In a few seconds the GenAlEx splash screen will appear, click to hide, the GenAIlEx
menu will appear in the Excel menu bar, just before the Help menu.
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Step 5. If you do not see the security warning dialog box and/or GenAlEx does not launch,
you may see the message below instead. In this case, continue to step 6.

Microsoft Excel

Macros are disabled because the security level is set to Very High. To run the macros, change the security level to a lower setting and verify the macros are signed and

. trusted.

Step 6. From the Excel menu Tools, choose Options. At the options dialog box click the
Macro Security button on the Security tab. In the next dialog box, choose Medium
for the security level. Now return to step 1 to launch GenAlEx.

Options @] Security @

View Calculation Edit General Transition Custom Lists Chart [ Security Level || Trusted Publishers

Color International Save Error Checking Spelling Security |

O Very High. Only macros installed in trusted locations will be allowed to run. All

File encryption settings for this workbook other signed and unsigned macros are disabled.

Password to open: () High. Only signed macros from trusted sources will be allowed to run, Unsigned
= macros are automatically disabled.

File sharing settings for this workbook

®

) Medium. You can chaose whether or not to run potentially unsafe macros.
Password to modify:

O

) Low (not recommended). You are not protected from patentially unsafe
[] Read-only recommended macros. Use this setting only if you have virus scanning software installed, or

you have checked the safety of all documents you open
Digital Signatures...

Privacy options
[] Remove persanal information from file properties on save

Macro security

Adiust the securiy level for files that might contain macra viruses and
specify names of trusted macro developers. LEetEst i

Optimizing Font Size for GenAlEx in Excel 2003 PC

GenAlEx output is optimized for a font size of 10 pt. If not already, you should therefore set the
Excel default font size to this setting.

Note that this setting does not over ride the font settings embedded in existing worksheets. To
ensure GenAlEx output is in 10 pt, you may wish to copy data (or data sheets) to new workbook that
has been created after the Excel default font is set to 10 pt as outlined below.

Step 1. From the Excel menu Tools, choose Options.

Step 2. At the options dialog box click the General tab. Set the standard font size to 10 pt.
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Options E]

Color International Save Error Checking Spelling Security
View Calculation Edit General | Transition | Custom Lists Chart
Settings
[CJR1c1 reference style ] Prompt for workbook properties
[ 1gnore other applications [ Provide feedback with sound
Function tooltips [[] zoom on roll with IntelliMouse
Recently used file list: |9 2 entries
[ Web Options... ] [ Service Options...
Sheets in new workbook: |1 :
Standard font: verdana v| size: |10 v
Default file location:
Atstartup, open all files in:
User name:

Loading GenAIEx in Excel 2004 on Mac

Instructions for loading GenAlEx in Excel 2004 (and setting default font size to 10 pt) on the
Macintosh are essentially similar to those for Excel 2003 on PC and so are not reproduced in detail

here.

Loading GenAIEx in Excel 2007 or Excel 2010 on PC

Step 1. Launch Excel 2007 or Excel 2010.

Step 2. In Excel 2007, open the GenAlEx Add-in via the Microsoft Office Button (top left of
screen). In Excel 2010, open the GenAlEx Add-in via the File menu.

Step 3. When prompted, by the Security Notice, choose Enable Macros.

Microsoft Office Excel Security Notice

@ i Office has i i a ial security concern.

Warning: It is not possible to determine that this content came
from a trustworthy source. You should leave this content disabled
unless the content provides critical functionality and you trust its
source.

File Path: C:\...s\Rod Peakall\Desktop\GenAlEx 6.091+\GenAlEx6_0975.xla

Macros have been disabled. Macros might contain viruses or other security
hazards. Do not enable this content unless you trust the source of this file.

More information

Enable Macros | [ Disable Macros_

Step 4. Shortly the GenAIlEx splash screen will appear.

Gandley.

Genetic Analysis in Excel

Version 6
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Step 5. Click the Add-Ins tab to show the Add-Ins ribbon. The GenAlEx menu will appear on
the right, along with any other installed Add-Ins you may be running. When using
GenAlEx you may find it convenient to turn off ‘Minimize Ribbon’ so that the
GenAlEx menu is always accessible when the Add-Ins ribbon is shown. You can
access this option by right-clicking the ribbon.

Optimizing Font Size for GenAIEx in Excel 2007 on PC

GenAlEx output is optimized for a font size of 10 pt. If not already, you should therefore set the
Excel default font size to this setting.

Note that this setting does not over ride the font settings embedded in existing worksheets. To
ensure GenAlEx output is in 10 pt, you may wish to copy data (or data sheets) to new workbook that
has been created after the Excel default font is set to 10 pt as outlined below.

Step 1. Click the Microsoft Office button (top left of screen), then Exce/ Options.
Step 2. Set the default Font Size for new workbooks to 10 pt under the option When
creating new workbooks.

When creating new workbooks

Use this font: Verdana v
Font size: 10 &

Default view for new sheets: | Normal View v

Include this many sheets: 3 2

Optimizing Font Size for GenAIEx in Excel 2010

GenAlEx output is optimized for a font size of 10 pt. If not already, you should therefore set the
Excel default font size to this setting.

Note that this setting does not over ride the font settings embedded in existing worksheets. To
ensure GenAlEx output is in 10 pt, you may wish to copy data (or data sheets) to new workbook that
has been created after the Excel default font is set to 10 pt as outlined below.

Step 1. Click the File menu, then click Options.
Step 2. From the Excel Options dialog choose General.
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Step 3. Set the default Font Size for new workbooks to 10 pt under the option When
creating new workbooks.

When creating new workbooks

Use this font: Verdana v
Font size: 10 v

Default view for new sheets: | Normal View v

Include this many sheets: 3 2

Loading GenAIEx in Excel 2011 on Intel Mac

Step 1. Launch Excel 2011.

Step 2. From within Excel, open the GenAlEx Add-in via the File menu.

Step 3. When prompted, by the Security Notice, choose Enable Macros.

Macros may contain viruses that could be harmful to your
computer. If this file is from a trusted source, click Enable Macros.
If you do not fully trust the source, click Disable Macros.

This workbook contains macros. Do you want to
X disable macros before opening the file?

Learn about macros

( Enable Macros \ ( Do Not Open \ ( Disable Macros )

Step 4. Shortly the GenAIlEx splash screen will appear.

éé Genetic Analysis in Excel
Version 6.4

Populstior

Step 5. Now you can access GenAlEx options from the GenAIEx menu.
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Optimizing Font Size for GenAlEx in Excel 2011 on Intel Mac

GenAlEx output is optimized for a font size of 10 pt on both PC and Mac. If not already, you
should therefore set the Excel default font size to this setting.

Note that this setting does not over ride the font settings embedded in existing worksheets. To
ensure GenAlEx output is in 10 pt, you may wish to copy data (or data sheets) to new workbook that
has been created after the Excel default font is set to 10 pt as outlined below.

Step 1. Click the Excel menu, then click Preferences.

Step 2. From the Excel Preferences dialog choose General.

Step 3. Set the default Font Size for new workbooks to 10 pt under the option Standard
font.

Step 4. Excel will warn that you must restart Excel for this option to take effect.

General

(-] jix] Q

Back/Forward Show All Search Excel Preferences

[ Use R1C1 reference style (] Prompt for workbook properties
() Provide feedback with sound
[) Confirm before opening other applications

™ Show this number of recent documents: |19 | (3]

= F YT ~r——
Ruler units: | Centimeters 14 Web Options... )

Sheets in new workbook: 1

Standard font: Verdana @ size: 10| @

Preferred file location: (" Select... )

————
At startup, open all files in: (" Select...
User name: Rod Peakall

() Open Excel Workbook Gallery when application opens.

Description

General

Controls general settings, such as some menu, sound, and appearance options.

(" cancel ) OK

Learning More About GenAIEXx

Extensive documentation about GenAlEx 6.5 is freely available from The Australian National
University, Canberra, Australia at the new website: http://biology.anu.edu.au/GenAlEx

A good place to start learning about GenAlEX is to access the self-paced tutorial modules that we
have provided on population genetic analysis. These tutorials are based on material we have
prepared to support our various graduate workshops and provide step-by-step instructions for using
GenAIEx to perform a wide range of population genetic analysis.

A Quick Start guide that includes some introductory exercises is also distributed with the GenAlEx
Add-in, but should not be seen as a substitute for completing these tutorials.

The GenAlEx 6.5 Appendix I document is also an invaluable source of information. This document
summarizes the methods and statistics available in GenAlEXx, along with more than 75 supporting
references.

Finally the fully revised guide to GenAlEx 6.5 comprehensively covers the many features offered
by GenAlIEXx.

Thank you for using GenAlEx!
Rod Peakall and Peter Smouse
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